PHP is among the most commonly used class-based programming languages. It is exceptionally popular since it is free software, which can be used to set up responsive sites like social networking websites, web stores or e-learning sites rather than static HTML sites. A PHP module must be available on the web server where a PHP website is hosted so that its PHP code can be ‘decoded’. As there are no license taxes for such a module and the language itself provides endless options for the applications that you build, there’re hundreds of millions of PHP-powered sites. Plus, there’re lots of open-source PHP-based scripts, which you can use for your sites without the need to have any programming expertise. As there’re a number of PHP versions, you should make certain that the same version that you used whilst setting up your website is installed on the server as well.
PHP 4 and PHP 5 Support in Cloud Web Hosting
With our cloud web hosting, you’ll be able to select the PHP version that will be active for your shared hosting account, since different versions are supported on our servers. With only one mouse click, you’ll be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and each time a new version is released in the future, we will include it in the Hepsia Control Panel without removing the earlier ones. Thus, you’ll be able to host all the websites that you’ve built over the years. In contrast with lots of other web hosting companies, we won’t force you to update such websites, because a script may be outdated, but this doesn’t mean that it’s insecure since you may have tweaked its source code to fill safety holes. For your convenience’s sake, you’ll even be able to select a different version of PHP for each website that you host in your hosting account.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
If you have a site built on an earlier PHP version and you’ve contributed time and efforts to setting it up, plugging security gaps and adding content, you will need to find a hosting service that can support it, since most web hosting providers nowadays offer support only for the most recent PHP version and remove the earlier versions. We, however, have decided to allow you to select the version that your own sites require. Our semi-dedicated servers support multiple versions of PHP 5 as well as PHP 4, which goes to say that you will be able to run both older and newer scripts without losing any manual modifications or wasting time trying to make your sites compatible with the hosting environment. The version can be changed through the Hepsia hosting Control Panel and such an update will apply to the entire semi-dedicated server account, but you’ll also be able to pick a different version for each individual site hosted in your account by means of an .htaccess file.